Amplifying your potential.

Failed loading or compiling necessary shaders.[maybe solved]

Full-scene Motion Blur for Unity Pro
4 posts • Page 1 of 1

Failed loading or compiling necessary shaders.[maybe solved]

Postby clayawodey » Sat Dec 19, 2015 5:39 pm

I was having this issue for a while and was trying to find out the reason.
Eventually I added

#pragma glsl

to the shaders that weren't compiling and that seemed to do the trick. Not sure if it is the proper fix. If it helps i'm still on Unity 4 and building for a mobile on OS X 10.10.5. Now if only I could get Amp Texture working ;).
clayawodey
 
Posts: 11
Joined: Mon Apr 28, 2014 11:42 am

Re: Failed loading or compiling necessary shaders.[maybe sol

Postby Ricardo Teixeira » Sat Dec 19, 2015 7:58 pm

Hello
clayawodey wrote:I was having this issue for a while and was trying to find out the reason.
Eventually I added

#pragma glsl

to the shaders that weren't compiling and that seemed to do the trick. Not sure if it is the proper fix. If it helps i'm still on Unity 4 and building for a mobile on OS X 10.10.5. Now if only I could get Amp Texture working ;).


Hello,

Thank you for letting us know, we will look into it as soon as possible. What Unity 4 and AM version do you currently use?

Do you have any projects currently in development using an older AT2 version in Unity 4?

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 615
Joined: Fri Aug 09, 2013 2:26 pm

Re: Failed loading or compiling necessary shaders.[maybe sol

Postby clayawodey » Wed Feb 03, 2016 8:36 am

I've been using 4.7 and will keep doing so as long as I can. Pretty sure I had the latest AM at the time of the issue.

I do 99% of my stuff for mobile or else I would be integrating AT2 into everything.. until then Substances and vertex shaders keep me semi sane.... but daddy needs his paint.... not numbers :D. My current game is 90% textures for driving the engagement... sooo whenever :lol:

take as much time as you need... i'll still be here in 10 years slowly increasing my expectations and feeling like i've purchase your other stuff for farrrrrr to little money.... :P .
clayawodey
 
Posts: 11
Joined: Mon Apr 28, 2014 11:42 am

Re: Failed loading or compiling necessary shaders.[maybe sol

Postby Ricardo Teixeira » Thu Feb 04, 2016 7:00 pm

No problem, we are in the process of fixing a few OSX related issues but I'll be sure to contact you as soon as we have any updates.

We really appreciate your vote of confidence, it's thanks to Amplify Texture 2 early adopters such as yourself that we made it this far. We are getting very close to a usable mobile version, we shall deliver ;)

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 615
Joined: Fri Aug 09, 2013 2:26 pm


4 posts • Page 1 of 1

Return to Amplify Motion

Who is online

Users browsing this forum: No registered users and 1 guest