Amplifying your potential.
Page 1 of 1

obsolete warnings

PostPosted: Mon Jan 28, 2019 11:43 am
by transat
FYI - I'm getting a few warnings in the Unity 2018.3 console referring to obsolete code in AmplifyColorEffectEditiorBase.cs

For example:

Code: Select all
[CompilerWarning] [CS0618] 'PrefabUtility.GetPrefabType(Object)' is obsolete:
'Use GetPrefabAssetType and GetPrefabInstanceStatus to get the full picture about Prefab types.'
Compiler Warning at Assets/AmplifyColor/Plugins/Editor/AmplifyColorEffectEditorBase.cs:72 column 33
70:   {
71:       GameObject effectPrefab = PrefabUtility.GetPrefabParent( effect.gameObject ) as GameObject;
-->72:       PrefabType effectPrefabType = PrefabUtility.GetPrefabType( effect.gameObject );
73:       bool effectIsPrefab = ( effectPrefabType != PrefabType.None && effectPrefabType != PrefabType.PrefabInstance );
74:       bool effectHasPrefab = ( effectPrefab != null );

Re: obsolete warnings

PostPosted: Tue Jan 29, 2019 11:07 am
by Amplify_Borba
Hello, thank you for getting in touch and for your support!

Unfortunately, Amplify Color does not officially support 2018.3 at this time and we can't provide any ETA, apologies for the inconvenience.