Amplifying your potential.

amplify texturing problem

Next-Gen Massive Virtual Texturing for Unity Pro
8 posts • Page 1 of 1

amplify texturing problem

Postby hackshaven » Sun Oct 26, 2014 3:35 pm

First off this looks like an amazing product! I downloaded the trial yesterday and made some good progress but am running into a problem with misplaced tiles. Basically I'm trying to create a high resolution Earth using NASA's Blue Marble. As you can see from the attached screen shots apparently in some circumstances I'm failing high school geography. Can you please assist?
Thanks,
Eric Hackathorn, NOAA
Attachments
texture setttings.jpg
texture setttings.jpg (167.82 KiB) Viewed 2726 times
material settings.jpg
material settings.jpg (180.55 KiB) Viewed 2726 times
amplify tiling.jpg
failing geography
amplify tiling.jpg (240 KiB) Viewed 2726 times
hackshaven
 
Posts: 9
Joined: Sun Oct 26, 2014 3:18 pm

Re: amplify texturing problem

Postby Ricardo Teixeira » Sun Oct 26, 2014 6:00 pm

Hello Eric,

Happy to hear it, thank you for evaluating Amplify Texture 2. Our virtualization technology is a great fit for your field of work.

Regarding the Multi-Tile use, the import process is fully automated, there is no need to adjust the tilling in the material options.

I would be happy to help you get started.

Are you using a sphere model with Multi-Tile UV’s generated in an external program, or is it generated via code directly in Unity?

From your screenshots it seems that you are using 8 UDIM Tile Textures, if that information is correct the problem would most likely be on the UV side. However, if you have more than 8 UDIM Tile Textures and they are not all added to the list automatically the problem might lie somewhere else.

Talk to you soon,

All the best,
Ricardo Teixeira
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 707
Joined: Fri Aug 09, 2013 2:26 pm

Re: amplify texturing problem

Postby hackshaven » Sun Oct 26, 2014 8:15 pm

That makes sense. I naively just created a sphere game object in the Unity editor and assumed it would work. It looks right with a single texture. :)
The import process set the material tiling to (0.25,0.5) for the eight tiles, but then I only saw the first (1001) texture on the sphere. That's why I manually set it back to (1,1).
So I should create the sphere using an external application and uv map it to use the 8 textures? Sorry for the basic questions.
Thanks,
Eric
PS if you're curious how we might use Amplify: http://www.esrl.noaa.gov/neis/library/terraviz-video.html
hackshaven
 
Posts: 9
Joined: Sun Oct 26, 2014 3:18 pm

Re: amplify texturing problem

Postby hackshaven » Mon Oct 27, 2014 3:16 pm

Hmm... So I tried my original setup on a Windows 7 machine this morning as opposed to the OSX 10.10 I used over the weekend and things look great! Is there any chance there could be a subtle difference between the Mac and Windows version of Amplify?
hackshaven
 
Posts: 9
Joined: Sun Oct 26, 2014 3:18 pm

Re: amplify texturing problem

Postby Ricardo Teixeira » Mon Oct 27, 2014 3:26 pm

Hello Eric,

No problem, I’m happy to help.

That’s great, Amplify Texture 2 really shines with that kind of data.

In order to use Multi-Tile UV’s you will have to adjust your models uv’s in an external program or adjust them directly in Unity, via code.

The process will vary depending on the model and workflow used but the the general idea is to assign Texture Tiles to each UV quadrant, using a compatible naming convention. In some cases a simple UV resize beyond the 0,1 UV Space will do it, for more irregular models the process might be a bit different.

I recommend checking the Multi-Tile UV Workflow section of the AT2 Manual for more information.

In your specific example, provided that the texture tiles are correct, all you need to do is to make sure the UV’s cover the 4x2 area.

By the way, if you want to do a quick check on tile collection with AT2, apply your earth tile collection to a unity terrain using the Amplify Texture 2 terrain shader. Terrains do not require pre-made Multi-Tile UV’s, you should have an accurate preview of your original data without any issues.

All the best,
Ricardo Teixeira
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 707
Joined: Fri Aug 09, 2013 2:26 pm

Re: amplify texturing problem

Postby Ricardo Teixeira » Mon Oct 27, 2014 3:27 pm

hackshaven wrote:Hmm... So I tried my original setup on a Windows 7 machine this morning as opposed to the OSX 10.10 I used over the weekend and things look great! Is there any chance there could be a subtle difference between the Mac and Windows version of Amplify?


Interesting, and you used a tile collection?
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 707
Joined: Fri Aug 09, 2013 2:26 pm

Re: amplify texturing problem

Postby hackshaven » Mon Oct 27, 2014 3:59 pm

Correct, a 4x2 collection of 8192x8192 textures.
hackshaven
 
Posts: 9
Joined: Sun Oct 26, 2014 3:18 pm

Re: amplify texturing problem

Postby Ricardo Teixeira » Mon Oct 27, 2014 4:49 pm

I was not aware that this was available in the latest public build, the version I was using internally would not allow me to change the tilling values when using a Multi-Tile collection.

It might indeed be a new issue, thank you for pointing it out.

Let us know if you run into any additional issues, any feedback is much appreciated.

All the best,
Ricardo Teixeira
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 707
Joined: Fri Aug 09, 2013 2:26 pm


8 posts • Page 1 of 1

Return to Amplify Texture 2 - Development Builds

Who is online

Users browsing this forum: No registered users and 1 guest