Amplifying your potential.

Terrain Shader Error?

Node-based Shader Editor
2 posts • Page 1 of 1

Terrain Shader Error?

Postby noio » Mon Dec 18, 2017 4:40 pm

Much love for the new terrain shader! Started trying it out immediately.

Just got this error under OpenGL4.1 on mac:

-------- GLSL link error: WARNING: Output of vertex shader 'vs_TEXCOORD5' not read by fragment shader
ERROR: Implementation limit of 16 active fragment shader samplers (e.g., maximum number of supported image units) exceeded, fragment shader uses 17 samplers


It does seem to work though.. :)
noio
 
Posts: 1
Joined: Mon Dec 18, 2017 4:39 pm

Re: Terrain Shader Error?

Postby Amplify_Borba » Mon Dec 18, 2017 5:25 pm

noio wrote:Much love for the new terrain shader! Started trying it out immediately.

Just got this error under OpenGL4.1 on mac:

-------- GLSL link error: WARNING: Output of vertex shader 'vs_TEXCOORD5' not read by fragment shader
ERROR: Implementation limit of 16 active fragment shader samplers (e.g., maximum number of supported image units) exceeded, fragment shader uses 17 samplers


It does seem to work though.. :)


Hello noio, thank you for getting in touch, we're glad you appreciate our new sample!

Regarding the error you're getting, I can confirm that its not an issue with the sample or the shader itself, but a limitation of the amount of textures being used for the selected shader model.

A simple workaround would be to increase it, but be aware that you should only take it up to 4.6 in OSX or 4.5 in iOS.

Please let us know if you have any further questions, thanks!
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 479
Joined: Mon Jul 24, 2017 9:50 am


2 posts • Page 1 of 1

Return to Amplify Shader Editor

Who is online

Users browsing this forum: Amplify_Borba, Google [Bot] and 3 guests