Amplifying your potential.

Amplify Occlusion: artifacts appear in Unity game view

Your feedback is very important to us. We are listening.
5 posts • Page 1 of 1

Amplify Occlusion: artifacts appear in Unity game view

Postby superstar » Tue Jan 10, 2017 6:58 am

Hi,

Unity 5.5.0p3 Pro
Amplify Occlusion 1.2.1 and 1.2.0
Windows 7 64-bit

There seems to be some kind of artifacts showing in the game view of Unity editor when switching application windows and then going back to the Unity editor while during play mode. For example, while running in play mode of the Unity editor, I switch to a Chrome web browser or any application, and then switch back the Unity editor.

Please see the attached files showing screenshots, one with artifacts and the other is a normal looking screen with no artifacts.

When the artifacts show up during run-time, I have to disable the AmplifyOcclusionEffect script and then enable it again to get rid of the artifacts.

Is there a setting I am overlooking? Can you confirm this is happening?

Thank you!
Attachments
no_artifacts.png
Normal looking screen
no_artifacts.png (73.5 KiB) Viewed 193 times
artifacts.png
Image showing artifacts on the screen
artifacts.png (119.78 KiB) Viewed 193 times
superstar
 
Posts: 3
Joined: Tue Jan 10, 2017 5:59 am

Re: Amplify Occlusion: artifacts appear in Unity game view

Postby superstar » Tue Jan 10, 2017 7:14 am

And, attached is a screenshot of the script settings.

Rendering Path is of Deferred
Attachments
script.png
script.png (35.54 KiB) Viewed 189 times
superstar
 
Posts: 3
Joined: Tue Jan 10, 2017 5:59 am

Re: Amplify Occlusion: artifacts appear in Unity game view

Postby Ricardo Teixeira » Tue Jan 10, 2017 11:38 am

superstar wrote:And, attached is a screenshot of the script settings.

Rendering Path is of Deferred


Hello,

Thank you for reporting the issue, we really appreciate it. There's a known Unity Editor issue that causes similar problems when alternating between windows, or when alternating between the Scene and Game view. However, this is an editor issue, it shouldn't be present during play or in the actual build, is that the case?

Looking forward to your feedback, thanks!
Sales & Customer Relations at Amplify Creations
User avatar
Ricardo Teixeira
 
Posts: 449
Joined: Fri Aug 09, 2013 2:26 pm

Re: Amplify Occlusion: artifacts appear in Unity game view

Postby superstar » Wed Jan 11, 2017 3:50 am

Ricardo Teixeira wrote:
superstar wrote:And, attached is a screenshot of the script settings.

Rendering Path is of Deferred


Hello,

Thank you for reporting the issue, we really appreciate it. There's a known Unity Editor issue that causes similar problems when alternating between windows, or when alternating between the Scene and Game view. However, this is an editor issue, it shouldn't be present during play or in the actual build, is that the case?

Looking forward to your feedback, thanks!



When running the build, everything looks good.

Just like you have mentioned, this happens when using the Unity editor and alternating between windows. It does also happen during play mode of the Unity editor's game view, while alternating windows during play mode. As you have mentioned, this is an editor issue, and thus I do understand.

I just wanted to confirm if it was a known editor issue or not. The actual build works good!

The Amplify Occlusion looks amazing! I am looking forward for hopefully more new features of it in the future.

Thank you!
superstar
 
Posts: 3
Joined: Tue Jan 10, 2017 5:59 am

Re: Amplify Occlusion: artifacts appear in Unity game view

Postby Ricardo Teixeira » Wed Jan 11, 2017 11:48 am

superstar wrote:
Ricardo Teixeira wrote:
superstar wrote:And, attached is a screenshot of the script settings.

Rendering Path is of Deferred


Hello,

Thank you for reporting the issue, we really appreciate it. There's a known Unity Editor issue that causes similar problems when alternating between windows, or when alternating between the Scene and Game view. However, this is an editor issue, it shouldn't be present during play or in the actual build, is that the case?

Looking forward to your feedback, thanks!



When running the build, everything looks good.

Just like you have mentioned, this happens when using the Unity editor and alternating between windows. It does also happen during play mode of the Unity editor's game view, while alternating windows during play mode. As you have mentioned, this is an editor issue, and thus I do understand.

I just wanted to confirm if it was a known editor issue or not. The actual build works good!

The Amplify Occlusion looks amazing! I am looking forward for hopefully more new features of it in the future.

Thank you!


Awesome, happy to know that it works in the actual build. It's a shame really, we hope that it's something that can be corrected at a later stage.

Be sure to contact us if you ever run into any additional problems, we would be more than happy to help.

Thanks!
Sales & Customer Relations at Amplify Creations
User avatar
Ricardo Teixeira
 
Posts: 449
Joined: Fri Aug 09, 2013 2:26 pm


5 posts • Page 1 of 1

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron