Amplifying your potential.
Page 1 of 1

Can't copy paste nodes, creating a "comment" overrides this

PostPosted: Thu Oct 11, 2018 2:02 am
by crazyfingers619
Holding the control keyboard button functions properly when wanting to select multiple nodes, but trying to hold control and press c to copy several nodes instead creates a comment box as if I were only pressing "C". Same for pressing control + v to paste.

Also pressing "C" doesn't require a left click to make the comment, it seems to happen immediately unlike other nodes and features. It's like there's a "quick comment" feature that is disrupting standard copy paste functionality.

Very frustrating, anyone know the solution to this issue? Been plaguing me for weeks and i've tried all kinds of updates and button combinations to try to fix this.

Re: Can't copy paste nodes, creating a "comment" overrides t

PostPosted: Thu Oct 11, 2018 8:35 am
by Amplify_Borba
Hello!

Pressing the 'C' key to create comments for the current selection or, if nothing is selected, in the current mouse position is intended behavior, however, you seem to be having an issue with copying and pasting nodes which isn't expected.

There was a similar bug that was fixed in the latest ASE version, but it only happened with the latest Unity Beta versions, which we don't officially support.

Could you please share the ASE and Unity versions that you're currently using in your project?

Re: Can't copy paste nodes, creating a "comment" overrides t

PostPosted: Fri Oct 12, 2018 4:49 am
by crazyfingers619
Image

I've used various recent beta builds, currently upgraded to the latest hoping it would fix it. IIRC the prior most recent non unity build had the same issue, but i may not have upgraded to the newest version then.

I also tried deleting the Amplify folder and re importing the package but still getting the issue...

If i could select nodes and right click and choose copy and paste another way this wouldn't be a big deal, but to my knowledge the only way to copy paste is with the keyboard shortcuts, which makes this entire package almost unusable for my purposes as i'm needing to restructure shaders and copy paste huge chunks at a time with proper naming.

Re: Can't copy paste nodes, creating a "comment" overrides t

PostPosted: Fri Oct 12, 2018 9:57 am
by Amplify_Borba
Thank you for sharing the screenshots, it appears that you're only running the latest ASE version from the Asset Store, however, we've released a few updates since then that are currently available on the build that you can download from our website.

Image

I apologize if I wasn't clear enough in my last reply, but you should always download the latest ASE version from our website since, due to our fast iteration times, we always upload the latest builds to our website first and, unless there has been some critical fix, we allow some time for further testing these before committing to submitting them to the Asset Store, which can also take a while to become avaliable there since it has to be reviewed by the Asset Store team beforehand.

In short, by downloading through our website you guarantee that you're always getting the most recent build.

I've also ran some further tests in Unity 2018.3.0b5 and haven't been able to replicate the issue, so please let me know if updating ASE helps!

Re: Can't copy paste nodes, creating a "comment" overrides t

PostPosted: Fri Oct 12, 2018 4:11 pm
by crazyfingers619
That did the trick!

Thanks for the timely replies and help wish i'd gotten around to posting this sooner but was hoping it would sort itself out within a couple weeks.

Not sure if it's Kosher with Unity but putting a link to that download page on the Unity Store might help others get the most recent updated versions of Amplify Shader that could help them with all kinds of potential issues, the Unity asset store page makes it seem like it's the most recent build:

1.5.6 (current)released Sep 6, 2018
* New Samples:
* SRP Lightweight Terrain
* Multi Pass Distortion
...

Re: Can't copy paste nodes, creating a "comment" overrides t

PostPosted: Mon Oct 15, 2018 2:08 pm
by Amplify_Borba
At this time, we always post regarding new updates and their availability on the Official ASE Thread over at the Unity Forums, as it's not possible to provide a link to our download page in the Asset Store description.

That being said, notifying users through the asset itself as each new update comes out is something that we've had on our minds, hopefully we can implement this or a similar solution in the near future. Thank you for your feedback!