Amplifying your potential.

use AS on PS4

Your feedback is very important to us. We are listening.
6 posts • Page 1 of 1

use AS on PS4

Postby icarus0508 » Mon Sep 11, 2017 9:45 am

Hi
We are using Amplify Shader Editor to make a PS4/PC game, however we had faced build error "Ambiguous call to "lerp()"" during PS4-building.

The reason is that the PS4 shader compiler can not decided function polymorphism, so in order to fix the problem we modified the final shader that ASE created.

My question is : Is this the proper way to fix the issue? Can I fix the problem by modify the editor setting? If it's a bug, do we have a future patch to fix it?

Thank You , Andrew
icarus0508
 
Posts: 3
Joined: Mon Sep 11, 2017 9:26 am

Re: use AS on PS4

Postby Ricardo Teixeira » Mon Sep 11, 2017 10:03 am

icarus0508 wrote:Hi
We are using Amplify Shader Editor to make a PS4/PC game, however we had faced build error "Ambiguous call to "lerp()"" during PS4-building.

The reason is that the PS4 shader compiler can not decided function polymorphism, so in order to fix the problem we modified the final shader that ASE created.

My question is : Is this the proper way to fix the issue? Can I fix the problem by modify the editor setting? If it's a bug, do we have a future patch to fix it?

Thank You , Andrew


Hello Andrew,

Thank you for bringing this issue to our attention, we really appreciate it. Can you share the solution directly to support@amplify.pt? We would be happy to look into an official fix ASAP.

What's your current Unity and ASE version?

We update ASE almost daily, you can always pick up the latest version directly from our website.

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 599
Joined: Fri Aug 09, 2013 2:26 pm

Re: use AS on PS4

Postby icarus0508 » Tue Sep 12, 2017 2:24 am

Sure I will love to share my result and version to you guys. Ty
icarus0508
 
Posts: 3
Joined: Mon Sep 11, 2017 9:26 am

Re: use AS on PS4

Postby icarus0508 » Tue Sep 12, 2017 4:29 am

Hi
I had sent you the email with the shader codes which face the error.
we tested on Unity 2017.1.0f3 with ASE V.1.02/v.1.03   PS4 SDK version is SDK4.508.101

Ty for helping

BR , Andrew :D
icarus0508
 
Posts: 3
Joined: Mon Sep 11, 2017 9:26 am

Re: use AS on PS4

Postby Ricardo Teixeira » Tue Sep 12, 2017 9:14 am

icarus0508 wrote:Hi
I had sent you the email with the shader codes which face the error.
we tested on Unity 2017.1.0f3 with ASE V.1.02/v.1.03   PS4 SDK version is SDK4.508.101

Ty for helping

BR , Andrew :D


Thanks Andrew, we will examine the sample and get back to you as soon as possible.
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 599
Joined: Fri Aug 09, 2013 2:26 pm

Re: use AS on PS4

Postby Ricardo Teixeira » Wed Oct 11, 2017 8:12 pm

Quick update,
The latest update should resolve the reported issues.

Latest version: Download
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 599
Joined: Fri Aug 09, 2013 2:26 pm


6 posts • Page 1 of 1

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest