Amplifying your potential.

Unity 2018.1.0f2 incompatible?

Node-based Shader Editor
10 posts • Page 1 of 1

Unity 2018.1.0f2 incompatible?

Postby Ozego » Mon May 14, 2018 11:05 am

Hi, I have been trying to upgrade our project to unity 2018 and Amplify is causing problems. I read on the store page that it should be compatible but I just cannot get it to work.
The problem seems to be with Unity dropping substance support. We do not use substance so I do not know much about this, but neither installing the substance unity asset not following allegorithmics tutorial on upgrading to 2018 worked.
The problem occurs both on our existing project and on vanilla unity projects only with Amplify Shader Editor imported.
Here is my error report:

Code: Select all
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Constants/ColorNode.cs(25,11): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(37,11): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(43,11): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/UndoParentNode.cs(237,142): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/UndoParentNode.cs(376,151): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/_MK/MKGlowFree/Editor/MKGlowFreeEditor.cs(95,55): warning CS0618: `UnityEditor.EditorGUILayout.ColorField(UnityEngine.GUIContent, UnityEngine.Color, bool, bool, bool, UnityEditor.ColorPickerHDRConfig, params UnityEngine.GUILayoutOption[])' is obsolete: `Use EditorGUILayout.ColorField(GUIContent label, Color value, bool showEyedropper, bool showAlpha, bool hdr, params GUILayoutOption[] options)'
Assets/Libs/_MK/MKGlowFree/Editor/MKGlowFreeEditor.cs(34,65): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Menu/AmplifyShaderEditorWindow.cs(578,22): warning CS0618: `UnityEditor.EditorApplication.projectWindowChanged' is obsolete: `Use EditorApplication.projectChanged'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Menu/AmplifyShaderEditorWindow.cs(578,22): warning CS0618: `UnityEditor.EditorApplication.projectWindowChanged' is obsolete: `Use EditorApplication.projectChanged'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Menu/AmplifyShaderEditorWindow.cs(873,22): warning CS0618: `UnityEditor.EditorApplication.projectWindowChanged' is obsolete: `Use EditorApplication.projectChanged'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Menu/AmplifyShaderEditorWindow.cs(873,22): warning CS0618: `UnityEditor.EditorApplication.projectWindowChanged' is obsolete: `Use EditorApplication.projectChanged'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Menu/AmplifyShaderEditorWindow.cs(2341,66): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Constants/ColorNode.cs(15,4): warning CS0618: `UnityEngine.ColorUsageAttribute.ColorUsageAttribute(bool, bool, float, float, float, float)' is obsolete: `Brightness and exposure parameters are no longer used for anything. Use ColorUsageAttribute(bool showAlpha, bool hdr)'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Constants/ColorNode.cs(19,4): warning CS0618: `UnityEngine.ColorUsageAttribute.ColorUsageAttribute(bool, bool, float, float, float, float)' is obsolete: `Brightness and exposure parameters are no longer used for anything. Use ColorUsageAttribute(bool showAlpha, bool hdr)'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Constants/ColorNode.cs(25,50): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Constants/ColorNode.cs(25,50): warning CS0612: `UnityEditor.ColorPickerHDRConfig' is obsolete
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Master/FallbackPickerHelper.cs(45,46): warning CS0618: `UnityEditorInternal.InternalEditorUtility.SetupShaderMenu(UnityEngine.Material)' is obsolete: `SetupShaderMenu is obsolete. You can get list of available shaders with ShaderUtil.GetAllShaderInfos'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SamplerNode.cs(32,255+): error CS0619: `UnityEngine.ProceduralTexture' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(11,129): error CS0246: The type or namespace name `SubstanceArchive' could not be found. Are you missing an assembly reference?
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(11,157): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(58,21): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(93,69): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(212,40): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(224,51): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(236,51): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(318,110): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(335,96): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(387,26): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(390,6): error CS0619: `UnityEngine.ProceduralTexture' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(390,51): error CS0619: `UnityEngine.ProceduralTexture' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(393,96): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(449,4): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(449,62): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(449,23): error CS0584: Internal compiler error: The method or operation is not implemented.
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(449,23): error CS0201: Only assignment, call, increment, decrement, await, and new object expressions can be used as a statement
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(496,76): error CS0619: `UnityEngine.ProceduralOutputType' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(629,58): error CS0619: `UnityEngine.ProceduralMaterial' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(629,5): error CS0584: Internal compiler error: The method or operation is not implemented.
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(629,5): error CS0201: Only assignment, call, increment, decrement, await, and new object expressions can be used as a statement
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/TexturePropertyNode.cs(310,30): error CS0619: `UnityEngine.ProceduralTexture' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/TexturePropertyNode.cs(511,26): error CS0619: `UnityEngine.ProceduralTexture' is obsolete: `Built-in support for Substance Designer materials has been removed from Unity. To continue using Substance Designer materials, you will need to install Allegorithmic's external importer from the Asset Store.'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/UndoParentNode.cs(239,37): warning CS0618: `UnityEditor.EditorGUILayout.ColorField(UnityEngine.GUIContent, UnityEngine.Color, bool, bool, bool, UnityEditor.ColorPickerHDRConfig, params UnityEngine.GUILayoutOption[])' is obsolete: `Use EditorGUILayout.ColorField(GUIContent label, Color value, bool showEyedropper, bool showAlpha, bool hdr, params GUILayoutOption[] options)'
Assets/Libs/AmplifyShaderEditor/Plugins/Editor/Nodes/UndoParentNode.cs(378,31): warning CS0618: `UnityEditor.EditorGUI.ColorField(UnityEngine.Rect, UnityEngine.GUIContent, UnityEngine.Color, bool, bool, bool, UnityEditor.ColorPickerHDRConfig)' is obsolete: `Use EditorGUI.ColorField(Rect position, GUIContent label, Color value, bool showEyedropper, bool showAlpha, bool hdr)'
-----EndCompilerOutput---------------


Btw thanks for an otherwise great product. I am the art director of a small game studio and since out technical artist left he recommended me to use your solution until we found a replacement for him... We never found a replacement for him.
Hope to hear from you soon.
Ozego
 
Posts: 4
Joined: Mon May 14, 2018 10:42 am

Re: Unity 2018.1.0f2 incompatible?

Postby Ricardo Teixeira » Mon May 14, 2018 11:10 am

Hello,

We would be happy to help, thank you for getting in touch.

Which Amplify Shader Editor version are you currently using?

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 948
Joined: Fri Aug 09, 2013 2:26 pm

Re: Unity 2018.1.0f2 incompatible?

Postby Ozego » Tue May 15, 2018 3:51 am

Thank you so much. I am importing it through the unity asset-store, which it claims it is 1.5.3, but the latest entry in the ChangeLog.txt is 1.4.2
Ozego
 
Posts: 4
Joined: Mon May 14, 2018 10:42 am

Re: Unity 2018.1.0f2 incompatible?

Postby Ozego » Tue May 15, 2018 8:47 am

Hi, it seems the problem is that the Unity Asset Store is sending me an old version. After downloading version 1.5.3 through your website everything resolved. Thank you.
Ozego
 
Posts: 4
Joined: Mon May 14, 2018 10:42 am

Re: Unity 2018.1.0f2 incompatible?

Postby Ricardo Teixeira » Tue May 15, 2018 10:05 am

Ozego wrote:Hi, it seems the problem is that the Unity Asset Store is sending me an old version. After downloading version 1.5.3 through your website everything resolved. Thank you.


Hello,

Thank you for letting us know!

Which Unity version did you use to download ASE from the Asset Store? Downloading it with a version higher than 5.5 should correct the previous issue.

Looking forward to your feedback!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 948
Joined: Fri Aug 09, 2013 2:26 pm

Re: Unity 2018.1.0f2 incompatible?

Postby Ozego » Tue May 15, 2018 10:46 am

Unity 2018.1.0f2 on MacOS High Sierra
Ozego
 
Posts: 4
Joined: Mon May 14, 2018 10:42 am

Re: Unity 2018.1.0f2 incompatible?

Postby Ricardo Teixeira » Tue May 15, 2018 10:50 am

Ozego wrote:Unity 2018.1.0f2 on MacOS High Sierra


Thanks for the heads up!

If possible, can you test it with another version?
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 948
Joined: Fri Aug 09, 2013 2:26 pm

Re: Unity 2018.1.0f2 incompatible?

Postby JohnnyFactor » Fri Nov 30, 2018 7:26 pm

I am encountering a similar issue. I imported the Substance plugin but then removed it later. Since removing it, Amplify is now giving this error:

Code: Select all
Assets/AmplifyShaderEditor/Plugins/Editor/Nodes/Textures/SubstanceSamplerNode.cs(673,11): error CS0246: The type or namespace name `Substance' could not be found. Are you missing an assembly reference?


I deleted both the Allegorithmic folder and the AmplifyShaderEditor folder and reimported only the AmplifyShaderEditor folder but the error persists.

Amplify Shader Editor 1.6.1
MacOS 10.14.1
Unity 2018.2.15 up to and including Unity 2018.2.18.
JohnnyFactor
 
Posts: 9
Joined: Thu Aug 16, 2018 2:43 pm

Re: Unity 2018.1.0f2 incompatible?

Postby RobRamsay » Fri Nov 30, 2018 9:24 pm

I too am hoping to convert many of my Amplify 2017 shaders to HDRP and having issues setting things up.

Just worried about what the console is saying..


Capture.PNG
Capture.PNG (167.47 KiB) Viewed 173 times


Now I get this when trying to make a material. What am I doing wrong?

Capture2.jpg
Capture2.jpg (168.86 KiB) Viewed 168 times
RobRamsay
 
Posts: 7
Joined: Sat Jun 09, 2018 12:01 pm

Re: Unity 2018.1.0f2 incompatible?

Postby Ricardo Teixeira » Mon Dec 03, 2018 11:51 am

Greetings everyone,

Let me start by assuring you that ASE is compatible with 2018.1. It seems that we have a couple of different issues on this thread, let's try to examine each one in order to determine the possible cause of the problem.

Ozego and JohnnyFactor

Does importing the latest ASE version (1.6.1) in a new empty project cause the same issue?

RobRamsay

1. Are Unity HD shaders working in that project? Be sure to set your project to linear.

2. What's your current HD SRP version and which HD Templates did you import?

3. Can you replicate the problem on a new Empty Project?
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 948
Joined: Fri Aug 09, 2013 2:26 pm


10 posts • Page 1 of 1

Return to Amplify Shader Editor

Who is online

Users browsing this forum: Frenk.1999.98K and 3 guests