Amplifying your potential.

unity 2018.3.6f1 with LW SRP

Your feedback is very important to us. We are listening.
5 posts • Page 1 of 1

unity 2018.3.6f1 with LW SRP

Postby 3d artist1987 » Fri Mar 01, 2019 10:28 am

Hi,

When I import LW SRP Samples this package in unity 2018.3.6f1 Then below error comes.

Shader properties can't be added to this global property sheet. Trying to add _GrabTexture_HDR (type 1 count 1)
UnityEditor.AssetPreviewUpdater:CreatePreviewForAsset(Object, Object[], String)

Thanks
3d artist1987
 
Posts: 36
Joined: Wed May 03, 2017 4:51 am

Re: unity 2018.3.6f1 with LW SRP

Postby Amplify_Borba » Fri Mar 01, 2019 2:47 pm

Hello, can you confirm that you're using the latest ASE version and that you've extracted the LWSRPTemplates.unitypackage?

Please note that you'll need to extract the templates package whenever you update your ASE version, in order to update older versions of the templates.

We've just tested a clean Unity 2018.3.6f1 project with LW RP v4.1.0 and the latest ASE version and we're not getting those errors with the LW samples.
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 1239
Joined: Mon Jul 24, 2017 9:50 am

Re: unity 2018.3.6f1 with LW SRP

Postby 3d artist1987 » Sat Mar 02, 2019 6:33 am

Hi,

Thanks for the reply.
Still, I did not get a result.
I send mail on this email id - support@amplify.pt

Thanks
3d artist1987
 
Posts: 36
Joined: Wed May 03, 2017 4:51 am

Re: unity 2018.3.6f1 with LW SRP

Postby Amplify_Borba » Thu Mar 07, 2019 11:54 am

Apologies for the delay in our response, I've just tested your project and the error wasn't present, however, I've noticed that the LW templates were not extracted, and these are needed for the samples to work.

In order to be able to author shaders for the LW SRP versions 4.8.0 through 4.10.0, you'll need to first extract the following package so that the necessary shader templates are made available:

AmplifyShaderEditor\Plugins\EditorResources\Templates\SRP\LWSRPTemplates.unitypackage

Our LW samples use these templates as well, so after extracting them the samples should work as expected.

Please let us know if this helps, thank you.
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 1239
Joined: Mon Jul 24, 2017 9:50 am

Re: unity 2018.3.6f1 with LW SRP

Postby 3d artist1987 » Fri Mar 29, 2019 10:40 am

Hi,

Thanks for reply
3d artist1987
 
Posts: 36
Joined: Wed May 03, 2017 4:51 am


5 posts • Page 1 of 1

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests