Amplifying your potential.

IOS Help, Shader fallsback

Node-based Shader Editor
2 posts • Page 1 of 1

IOS Help, Shader fallsback

Postby killa2471 » Wed Aug 08, 2018 5:02 am

Hello, I am working with a shader that works with Android but not IOS workstation (Not 100% sure if it works on IOS phones/devices). I am creating these shader for a client who is creating these builds and testing them, however there is no way for me to tell what he is testing them on.

The shader falls back to the pink shader when he plays them on his machine (Which has no GPU if that matters), any advice or help for my situation would be great.

Thank you.

38712026_270540060211963_1854562871208312832_n.jpg
38712026_270540060211963_1854562871208312832_n.jpg (97.94 KiB) Viewed 21 times
killa2471
 
Posts: 1
Joined: Wed Aug 08, 2018 4:53 am

Re: IOS Help, Shader fallsback

Postby Amplify_Borba » Wed Aug 08, 2018 9:39 am

Hello, thank you for getting in touch and for your support!

Without knowing more details regarding the shader and the target device, it can be hard to pinpoint the issue, however, you could try setting a fallback shader with a lower Shader Model, as it seems that certain passes/features might not be supported in that specific device by the main shader, leading to the pink shader since there's no available or compatible shader to fallback to.

Please let me know if this helps, thanks!
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 616
Joined: Mon Jul 24, 2017 9:50 am


2 posts • Page 1 of 1

Return to Amplify Shader Editor

Who is online

Users browsing this forum: No registered users and 1 guest

cron