Amplifying your potential.

A few questions about workflow and copying nodes

Node-based Shader Editor
2 posts • Page 1 of 1

A few questions about workflow and copying nodes

Postby sethhall » Fri Aug 10, 2018 1:04 am

HI!

I tend to work in a way that allows me to prototype in a Test folder outside of the scope of the project. This means I can work non-destructively on assets while I am prototyping. Typically I'll build my shaders like this, in a silo and when they're ready to integrate back into the project I'll copy the data into a newly created shader that can then be wired up.

I should preface by saying that I am working on OSX.

First, when copy\pasting nodes from one shader or function to another I lose all of my custom Property and Variable Names. It's a huge pain to have to go back to the original shader I prototyped and start re-typing in all of the properties and variables. As a result of the variables, typically none of my Variable Get nodes retain their connections, therefore I also have to go back and start determining what was wired where. Some of these shaders are a little complex. Would you guys be able to resolve this type of issue?

Second, if I have nodes selected in the graph and then grab the Graph Menu Bar to move the window to another location on the screen... Whatever nodes are actively selected will shoot off into the ethos of the entire graph in the direction that I pull the window. This can be frustrating from a workflow perspective because I tend to spend a bit too much time trying to get my graphs all neatly arranged and lined up so they're easy to read. Have you encountered this? I can email you a video if you'd like since I can't attach one on here.

Thanks!

Seth
sethhall
 
Posts: 6
Joined: Mon Jun 25, 2018 11:09 pm

Re: A few questions about workflow and copying nodes

Postby Amplify_Borba » Fri Aug 10, 2018 9:28 am

Hello Seth, thank you for taking the time to provide us with your feedback!

Your first suggestion might be possible to achieve, I'll be registering it to the developers so they investigate it and we'll get back to you as soon as we know if it's doable.

Regarding the second one, I believe that there's not much that can be done in regards to this type of issue when using the editor across multiple screens since it's likely to be Unity related, however, we're going to look into possible workarounds and will let you know if we come up with a viable fix. If you could provide a video through support@amplify.pt it would be great as it could help us in debugging this.

Please let me know if you have any further feedback, we really appreciate it!
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 616
Joined: Mon Jul 24, 2017 9:50 am


2 posts • Page 1 of 1

Return to Amplify Shader Editor

Who is online

Users browsing this forum: No registered users and 1 guest