Amplifying your potential.
Page 1 of 1

Why it's displaying blur effect behind obstacle?

PostPosted: Wed Mar 14, 2018 3:40 am
by zhuchun
Hi, each carriage has its own AmplifyMotionObject component, but the effect is displaying even when the carriage is behind an opaque object. How can I fix this?

Snapshot has been attached.

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Wed Mar 14, 2018 10:57 am
by Amplify_Borba
Hello zhuchun, thank you for getting in touch!

Could you confirm if the objects not meant to be affected by the motion blur effect are set to static, and if all the moving/dynamic objects have the Amplify Motion Object component applied to them?

Looking forward to your reply!

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Thu Mar 15, 2018 8:51 am
by zhuchun
Yes, the whole building is a static gameObject and all carriages have their own AmplifyMotionObject. AutoRegister has been disabled as well.

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Thu Mar 15, 2018 10:32 am
by Amplify_Borba
Could you provide us a simple sample with the issue present, as this is not intended behavior and we can't seem to replicate it on our side?

Also, what Unity version are you currently using on your project?

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Mon Mar 19, 2018 10:02 am
by zhuchun
Hi, sorry for my late reply, I'm having trouble when trying to make a repro.

Here's a simple scene, it works good on my new project but fails on my existing project. I'm wondering if there's any project settings could lead to this?

Image

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Mon Mar 19, 2018 12:14 pm
by Amplify_Borba
There shouldn't be many reasons for this issue to manifest itself, unfortunately, it's complicated to pinpoint a possible cause for it without a sample project for us to debug on our side.

A video with debug mode on while showing the issue present in your main project might also be helpful.

Looking forward to your reply!

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Tue Mar 20, 2018 10:22 am
by zhuchun
Thanks for your reply. The problem has gone after I completely re-import this asset, so I guess it's either merge or upgrade broke some files. Anyway, don't bother anymore, cheers! :D

Re: Why it's displaying blur effect behind obstacle?

PostPosted: Tue Mar 20, 2018 3:53 pm
by Amplify_Borba
No problem, glad to know that it wasn't an issue on our side, thank you for reporting back with your findings.

Please don't hesitate to get back in touch if you have any further questions!