Amplifying your potential.

Amplify LUT - Empty Browser

Advanced Color Grading for Unity Pro
10 posts • Page 1 of 1

Amplify LUT - Empty Browser

Postby Nswayze » Thu Dec 01, 2016 4:51 am

I'm running Unity 5.05ob10 Pro and I purchased Amplify Colour + Amplify LUT a couple of hours ago. Since Installing it I haven't been able to get any previews in the Amplify LUT browser.

I've put my receipt number in and downloaded AmplifyColor_v164 + The Lutpack.zip Imported them then made a new scene, making sure my camera has the amplify colour effect script on it.

But there's still no luck. I'm running Windows 7
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Nswayze » Thu Dec 01, 2016 6:07 am

Update:

I've installed Unity 5.50b11, created a new scene, imported the colour asset first then the lut asset and still no luck. The browser has nothing to choose from and I get these errors using 1.6.4_dev001;


Code: Select all
Compilation succeeded - 11 warning(s)
-----CompilerOutput:-stderr----------
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(146,33): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(149,35): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(149,74): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticTruecolor' is obsolete: `Use textureCompression property instead'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(200,71): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(201,19): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(201,58): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticCompressed' is obsolete: `Use textureCompression property instead'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(204,16): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(206,54): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticCompressed' is obsolete: `Use textureCompression property instead'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(206,16): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(233,57): warning CS0252: Possible unintended reference comparison. Consider casting the left side expression to type `UnityEngine.Texture2D' to get value comparison
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(406,119): warning CS0252: Possible unintended reference comparison. Consider casting the left side expression to type `AmplifyColor.LUTBrowser' to get value comparison
-----EndCompilerOutput---------------
- Finished compile Library/ScriptAssemblies/Assembly-CSharp-Editor.dll
WeaveUnetFromEditor Temp/Assembly-CSharp-Editor.dll
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/Advertisements/UnityEngine.Advertisements.dll' because we're compiling for Editor
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/GUISystem/Standalone/UnityEngine.UI.dll' because we're compiling for Editor
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/Networking/Standalone/UnityEngine.Networking.dll' because we're compiling for Editor
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/UnityHoloLens/Runtime/UnityEngine.HoloLens.dll' because we're compiling for Editor
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/UnityPurchasing/UnityEngine.Purchasing.dll' because we're compiling for Editor
Ignoring 'C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/UnityVR/Runtime/UnityEngine.VR.dll' because we're compiling for Editor
WeaveAssemblies unityPath= C:/Program Files/Unity 5.5.0b11/Editor/Data/Managed/UnityEngine.dll
WeaveAssemblies unetPath= C:/Program Files/Unity 5.5.0b11/Editor/Data/UnityExtensions/Unity/Networking/UnityEngine.Networking.dll
Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(146,33): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 146)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(149,35): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 149)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(149,74): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticTruecolor' is obsolete: `Use textureCompression property instead'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 149)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(200,71): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 200)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(201,19): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 201)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(201,58): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticCompressed' is obsolete: `Use textureCompression property instead'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 201)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(204,16): warning CS0618: `UnityEditor.TextureImporter.linearTexture' is obsolete: `linearTexture Property deprecated. Use sRGBTexture instead.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 204)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(206,54): warning CS0618: `UnityEditor.TextureImporterFormat.AutomaticCompressed' is obsolete: `Use textureCompression property instead'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 206)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(206,16): warning CS0618: `UnityEditor.TextureImporter.textureFormat' is obsolete: `textureFormat is not longer accessible at the TextureImporter level. For old 'simple' formats use the textureCompression property for the equivalent automatic choice (Uncompressed for TrueColor, Compressed and HQCommpressed for 16 bits). For platform specific formats use the [[PlatformTextureSettings]] API. Using this setter will setup various parameters to match the new automatic system as well possible. Getter will return the last value set.'
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 206)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(233,57): warning CS0252: Possible unintended reference comparison. Consider casting the left side expression to type `UnityEngine.Texture2D' to get value comparison
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 233)

Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs(406,119): warning CS0252: Possible unintended reference comparison. Consider casting the left side expression to type `AmplifyColor.LUTBrowser' to get value comparison
 
(Filename: Assets/AmplifyColor/Plugins/Editor/LUTBrowser.cs Line: 406)
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Ricardo Teixeira » Thu Dec 01, 2016 11:01 am

Hello,

Apologies for the inconvenience, the browser included in the Amplify LUT Pack does not support Unity 5.5, an update will be available shortly. Be sure to use the Amplify Color version downloaded from our website, it includes 5.5 support not yet available in the Unity Asset Store version.

We will let you know as soon as the LUT package is updated. Until then, you can always use the LUT's manually, be sure to exclude the Browser when importing the package.

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 954
Joined: Fri Aug 09, 2013 2:26 pm

Re: Amplify LUT - Empty Browser

Postby Nswayze » Thu Dec 01, 2016 12:07 pm

Okay. Thank you for the fast reply. At least now I know what's going on. I'll keep my eyes open for the LUT update and just use Amplify Colour for now. Have a good day.
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Ricardo Teixeira » Thu Dec 01, 2016 12:24 pm

Nswayze wrote:Okay. Thank you for the fast reply. At least now I know what's going on. I'll keep my eyes open for the LUT update and just use Amplify Colour for now. Have a good day.


Hello,

We updated the package, be sure to grab the latest version from our own Download Page. The Asset Store version should be available in a couple of weeks.

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 954
Joined: Fri Aug 09, 2013 2:26 pm

Re: Amplify LUT - Empty Browser

Postby Nswayze » Thu Dec 01, 2016 1:46 pm

Awesome. So far it's working flawlessly. Thank you for being so fast to read my messages and resolve the problems. Really great customer support :)
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Nswayze » Thu Dec 01, 2016 2:26 pm

This might just be me being a noob and not know how to use the app properly but I noticed some of the cameras in my scene were darker than others so I copied their values and pasted them into the other camera amplify scripts and noticed that placed the lut texture on them.

Then as I tried to figure out why the colour wasn't being applied I clicked on the apply button and saw

"InvalidCastException: Cannot cast from source type to destination type"

I dunno what that means but think it has something to do with it.
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Ricardo Teixeira » Thu Dec 01, 2016 3:29 pm

Hello,

Apologies for the inconvenience, there was a small issue with the uploaded build. We replaced the LUT package, please download it again and let us know if you find any additional errors.

Thank you for your feedback, we really appreciate it.

Note: The "Apply" area is actually a label, it's easy to confuse it with a button. Clicking on a LUT automatically applies it to the selected camera.
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 954
Joined: Fri Aug 09, 2013 2:26 pm

Re: Amplify LUT - Empty Browser

Postby Nswayze » Sun Dec 04, 2016 7:32 am

Thank you. You provided me with some really awesome support and, I'll be buying your other assets in the future :)




Side Note for anyone else with similar issues:

Once you install the latest updated versions. You need to make a new camera and apply the components. Figured out the long way it doesn't work on pre-existing cameras in the scene :P
Nswayze
 
Posts: 6
Joined: Thu Dec 01, 2016 4:46 am

Re: Amplify LUT - Empty Browser

Postby Ricardo Teixeira » Sun Dec 04, 2016 3:00 pm

Nswayze wrote:Thank you. You provided me with some really awesome support and, I'll be buying your other assets in the future :)

Side Note for anyone else with similar issues:

Once you install the latest updated versions. You need to make a new camera and apply the components. Figured out the long way it doesn't work on pre-existing cameras in the scene :P


Hello,

No problem, happy to help. Regarding the pre-existing cameras, you do not need to make new cameras. Can you elaborate on the problem? We would be happy to help debug it.

Be sure to update to the latest Unity 5.5 release, beta versions are no longer officially supported.

Thanks!
Sales & Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Ricardo Teixeira
 
Posts: 954
Joined: Fri Aug 09, 2013 2:26 pm


10 posts • Page 1 of 1

Return to Amplify Color

Who is online

Users browsing this forum: No registered users and 1 guest