Amplifying your potential.

Merging imposter meshes not working

1-Click Impostor Creator
2 posts • Page 1 of 1

Merging imposter meshes not working

Postby ascherren » Tue Aug 21, 2018 10:16 am

Hi,

we are trying to merge Amplify Imposter meshes in order to improve performance in WebGL.
There on our target hardware we notice that even 5.000 Quads with GPU batching are like 80-90% less performing than combining those quads into one big mesh.

Therefore we would like to do the same with Amplify Imposters.

Combined Imposters with default shader:
Image

Combined Imposters with Imposter shader:
Image

Is there anything you or we can do to make this possible?

Regards,
Andreas
ascherren
 
Posts: 1
Joined: Tue Aug 21, 2018 10:10 am

Re: Merging imposter meshes not working

Postby Amplify_Borba » Tue Aug 21, 2018 1:36 pm

Hello Andreas, thank you for getting in touch and for your support!

Unfortunately, you've stumbled upon a limitation for which we are hoping to find a workaround.
In short, we plan to investigate a way of performing this sort of optimization through different LOD systems in the future, including the Hierarchical Level of Detail - HLOD, in a way that users won't have to worry about merging the meshes as everything should be taken care of by the tool.

That being said, there is no official ETA for this specific feature as we're currently focused on improving the UX and fixing reported issues as the tool is still in Beta, so stay tuned for future updates!
Customer Relations at Amplify Creations
Learn more about our offering: Amplify Creations Products
Amplify Shader Editor won the Asset Store Best Tool Award - Thank you for your support!
User avatar
Amplify_Borba
 
Posts: 1239
Joined: Mon Jul 24, 2017 9:50 am


2 posts • Page 1 of 1

Return to Amplify Impostors

Who is online

Users browsing this forum: No registered users and 1 guest